Requirements

System Requirement to run your flutter mobile app on your machine.

Project Requirement

Make sure to download the following installation bundle to get the latest beta release of the Flutter SDK (for other release channels, and older builds, see the SDK archive page). If you need more info on how to setup project, please follow Flutter Getting Started at Flutter official websites

Flutter SDK

Download the following installation bundle to get the latest release of the Flutter SDK (for other release channels, and older builds, see the SDK archive page.):

Please follow Flutter installation guide on there official website

Extract the file in the desired location :

In Linux and MACOS:

cd ~/development
tar xf ~/Downloads/flutter_linux_v1.7.8+hotfix.4-stable.tar.xz

In Window go to:

1 . C:\Program Files\

2. Locate the file flutter_console.bat inside the flutter directory. Start it by double-clicking.

Create a Demo Flutter Project:

In the android studio, you can find an option to create a new flutter project there you can select flutter application, click on next there you can mention your project name click on next, enter your company domain click on finish .your flutter project gets created.

Create a simple, template Flutter app, using the instructions in Getting Started with your first Flutter app.

Tip: If you don’t see “New Flutter Project” as an option in your IDE, make sure you have the plugins installed for Flutter and Dart.

You can install the plugins by following the below step:

Go to Android studio>File>Plugins>install flutter>install dart(this will download your flutter and dart files )

flutter create your_project_name

Type the Below command in your CMD to run flutter project :

** $ flutter run **

Install the packages of flutter :

** $ flutter packages get **

Run flutter doctor:

** $ flutter doctor **